tcp ip之外的3种协议(除了tcp ip协议的网络外还有什么协议的网络)

:暂无数据 2026-09-16 09:10:06 :3

tcp ip之外的3种协议(除了tcp ip协议的网络外还有什么协议的网络)

各位老铁们好,相信很多人对tcp ip之外的3种协议都不是特别的了解,因此呢,今天就来为大家分享下关于tcp ip之外的3种协议以及除了tcp ip协议的网络外还有什么协议的网络的问题知识,还望可以帮助大家,解决大家的一些困惑,下面一起来看看吧!

本文目录

除了tcp ip协议的网络外还有什么协议的网络

计算机的使用中还要经常用到IPX/SPX协议,比如多机联红警等游戏时就需要IPX协议。
IPX(Internet work Packet Exchange,互联网络数据包交换)是一个专用的协议簇,它主要由Novell NetWare操作系统使用。IPX是IPX协议簇中的第三层协议。SPX(Sequenced Packet Exchange protocol, 序列分组交换协议)序列分组交换协议(SPX)是 Novell 早期传输层协议,为 Novell NetWare 网络提供分组发送服务。在局域网中用得的比较多的网络协议是IPX/SPX.。

网络层协议有哪些

网络层协议有:

1、ARP协议:

地址解析协议,即ARP(Address Resolution Protocol),是根据IP地址获取物理地址的一个TCP/IP协议。

主机发送信息时将包含目标IP地址的ARP请求广播到局域网络上的所有主机,并接收返回消息,以此确定目标的物理地址;收到返回消息后将该IP地址和物理地址存入本机ARP缓存中并保留一定时间,下次请求时直接查询ARP缓存以节约资源。

2、IP协议:

IP是Internet Protocol(网际互连协议)的缩写,是TCP/IP体系中的网络层协议。设计IP的目的是提高网络的可扩展性:一是解决互联网问题,实现大规模、异构网络的互联互通;二是分割顶层网络应用和底层网络技术之间的耦合关系,以利于两者的独立发展。根据端到端的设计原则,IP只为主机提供一种无连接、不可靠的、尽力而为的数据包传输服务。

3、ICMP协议:

ICMP(Internet Control Message Protocol)Internet控制报文协议。它是TCP/IP协议簇的一个子协议,用于在IP主机、路由器之间传递控制消息。控制消息是指网络通不通、主机是否可达、路由是否可用等网络本身的消息。这些控制消息虽然并不传输用户数据,但是对于用户数据的传递起着重要的作用。

4、IGMP协议:

互联网组管理协议(IGMP,Internet Group Management Protocol)是因特网协议家族中的一个组播协议。

TCP/IP协议族的一个子协议,用于IP主机向任一个直接相邻的路由器报告他们的组成员情况。允许Internet主机参加多播,也是IP主机用作向相邻多目路由器报告多目组成员的协议。多目路由器是支持组播的路由器,向本地网络发送IGMP查询。主机通过发送IGMP报告来应答查询。组播路由器负责将组播包转发到所有网络中组播成员。

5、互联网组管理协议 

互联网组管理协议 是对应于开源系统互联(OSI)七层框架模型中网络层的协议。在互联网工程任务组(The Internet Engineering Task Force,简称IETF)编写的标准文档(RFC)2236.中对Internet组管理协议(IGMP)做了详尽的描述。

计算机除了有网络协议也就是TCP/IP协议以外,还有什么协议呢

计算机网络协议:
应用层
  ·DHCP(动态主机分配协议)   · DNS (域名解析)   · FTP(File Transfer Protocol)文件传输协议   · Gopher (英文原义:The Internet Gopher Protocol 中文释义:(RFC-1436)网际Gopher协议)   · HTTP (Hypertext Transfer Protocol)超文本传输协议   · IMAP4 (Internet Message Access Protocol 4) 即 Internet信息访问协议的第4版本   · IRC (Internet Relay Chat )网络聊天协议   · NNTP (Network News Transport Protocol)RFC-977)网络新闻传输协议   · XMPP 可扩展消息处理现场协议   · POP3 (Post Office Protocol 3)即邮局协议的第3个版本   · SIP 信令控制协议   · SMTP (Simple Mail Transfer Protocol)即简单邮件传输协议   · SNMP (Simple Network Management Protocol,简单网络管理协议)   · SSH (Secure Shell)安全外壳协议   · TELNET 远程登录协议   · RPC (Remote Procedure Call Protocol)(RFC-1831)远程过程调用协议   ·RTCP (RTP Control Protocol)RTP 控制协议   · RTSP (Real Time Streaming Protocol)实时流传输协议   · TLS (Transport Layer Security Protocol)安全传输层协议   · SDP( Session Description Protocol)会话描述协议   · SOAP (Simple Object Access Protocol)简单对象访问协议   · GTP 通用数据传输平台   · STUN(Simple Traversal of UDP over NATs,NAT 的UDP简单穿越)是一种网络协议   · NTP (Network Time Protocol)网络校时协议
传输层
  ·TCP(Transmission Control Protocol) 传输控制协议   · UDP (User Datagram Protocol) 用户数据报协议   · DCCP (Datagram Congestion Control Protocol)数据报拥塞控制协议   · SCTP(STREAM CONTROL TRANSMISSION PROTOCOL)流控制传输协议   · RTPReal-time Transport Protocol或简写RTP)实时传送协议   · RSVP (Resource ReSer Vation Protocol)资源预留协议   · PPTP ( Point to Point Tunneling Protocol)点对点隧道协议
网络层
  IP (IPv4 · IPv6) · ARP · RARP · ICMP · ICMPv6 · IGMP · RIP · OSPF · BGP · IS-IS · IPsec
数据链路层
  802.11 · 802.16 · Wi-Fi · WiMAX · ATM · DTM · 令牌环 · 以太网 · FDDI · 帧中继 · GPRS · EVDO · HSPA · HDLC · PPP · L2TP · ISDN
物理层
  以太网物理层 · 调制解调器 · PLC · SONET/SDH · G.709 · 光导纤维 · 同轴电缆 · 双绞线

局域网常用协议有哪几个

网络协议
  
1、协议:通信双方所共同遵守的规则。
  
2、网络协议:计算机在网络中实现通信时必须遵守的规则和约定。
  
每个网络中至少要选择一种网络协议。具体选择哪一种网络通信协议主要取决于网络的规模、网络的兼容性和网络管理等几个方面。常接触的局域网中,一般使用NETBEUT、IPX/SPX和TCP/IP三种协议。
  NETBEUI:是为IBM开发的非路由协议,用于携带NETBIOS通信。NETBEUI缺乏路由和网络层寻址功能,既是其最大的优点,也是其最大的缺点。因为它不需要附加的网络地址和网络层头尾,所以很快并很有效且适用于只有单个网络或整个环境都桥接起来的小工作组环境。
  IPX/SPX:它是由Novell提出的用于客户/服务器相连的网络协议。使用IPX/SPX协议能运行通常需要NetBEUI支持的程序,通过IPX/SPX协议可以跨过路由器访问其他网络。IPX具有完全的路由能力,可用于大型企业网。
  TCP/IP:TCP/IP是在60年代由麻省理工学院和一些商业组织为美国国防部开发的,即便遭到核攻击而破坏了大部分网络,TCP/IP仍然能够维持有效的通信。TCP/IP同时具备了可扩展性和可靠性的需求。每种网络协议都有自己的优点,但是只有TCP/IP允许与Internet完全的连接。TCP/IP的32位寻址功能方案不足以支持即将加入Internet的主机和网络数。因而可能代替当前实现的标准是IPv6。

网络层分为哪几种协议

TCP/IP网络层的核心是IP协议,与IP协议配套使用实现其功能的还有地址解析协议ARP、逆地址解析协议RARP、因特网报文协议ICMP、因特网组管理协议IGMP。

拓展阅读:

网络层是OSI模型中的第三层。网络层提供路由和寻址的功能,使两终端系统能够互连且决定最佳路径,并具有一定的拥塞控制和流量控制的能力。TCP/IP协议体系中的网络层功能由IP协议规定和实现,故又称IP层。网络层介于运输层和数据链路层之间,它在数据链路层提供的两个相邻端点之间的数据帧的传送功能上,进一步管理网络中的数据通信,将数据设法从源端经过若干个中间节点传送到目的端,从而向运输层提供最基本的端到端的数据传送服务。主要内容有:虚电路分组交换和数据报分组交换、路由选择算法、阻塞控制方法、X.25协议、综合业务数据网(ISDN)、异步传输模式(ATM)及网际互连原理与实现。

目的功能

网络层的目的是实现两个端系统之间的数据透明传送,具体功能包括寻址和路由选择、连接的建立、保持和终止等。它提供的服务使传输层不需要了解网络中的数据传输和交换技术。如果您想用尽量少的词来记住网络层,那就是“路径选择、路由及逻辑寻址”。

为了说明网络层的功能,如图4.1所示的交换网络拓扑结构,它是由若干个网络节点按照任意的拓扑结构相互连接而成的。网络层关系到通信子网的运行控制,体现了网络应用环境中资源子网访问通信子网的方式。网络层从物理上来讲一般分布地域宽广,从逻辑上来讲功能复杂,因此是OSI模型中面向数据通信的下三层(也即通信子网)中最为复杂也最关键的一层。

在Windows 网络中除使用TCP/IP外,还可以使用哪些协议

FTP
HTTP等都是网络中常用的协议
但是与TCP/IP一类的
网络通讯协议
的话,一般还有IPX协议、
IPV6协议
等。

常见的三个网络协议的区别:TCP/IP、NetBEUI、IPX/SPX

【问:】NetBEUI和IPX/SPX TCP/IP 这三个协议到底是干什么的??尤其是前两个,有的时候就装,有时候就不装,到底为什么呢??它们有什么区别和独到之处呢?什么时候必须装呢?

【答:】这个问题问到的网友不少,查阅并综合了相关资料,给大家作一个详细的讲解。

网络协议(Protocol)是一种特殊的软件,是计算机网络实现其功能的最基本机制。网络协议的本质是规则,即各种硬件和软件必须遵循的共同守则。网络协议并不是一套单独的软件,它融合于其他所有的软件系统中,因此可以说,协议在网络中无所不在。网络协议遍及OSI通信模型的各个层次,从我们非常熟悉的TCP/IP、HTTP、FTP协议,到OSPF、IGP等协议,有上千种之多。对于普通用户而言,不需要关心太多的底层通信协议,只需要了解其通信原理即可。在实际管理中,底层通信协议一般会自动工作,不需要人工干预。但是对于第三层以上的协议,就经常需要人工干预了,比如TCP/IP协议就需要人工配置它才能正常工作。

局域网常用的三种通信协议分别是TCP/IP协议、NetBEUI协议和IPX/SPX协议。 TCP/IP协议毫无疑问是这三大协议中最重要的一个,作为互联网的基础协议,没有它就根本不可能上网,任何和互联网有关的操作都离不开TCP/IP协议。不过TCP/IP协议也是这三大协议中配置起来最麻烦的一个,单机上网还好,而通过局域网访问互联网的话,就要详细设置IP地址,网关,子网掩码,DNS服务器等参数。

TCP/IP尽管是目前最流行的网络协议,但TCP/IP协议在局域网中的通信效率并不高,使用它在浏览“网上邻居”中的计算机时,经常会出现不能正常浏览的现象。此时安装NetBEUI协议就会解决这个问题。

NetBEUI即NetBios Enhanced User Interface ,或NetBios增强用户接口。它是NetBIOS协议的增强版本,曾被许多操作系统采用,例如Windows for Workgroup、Win 9x系列、Windows NT等。NETBEUI协议在许多情形下很有用,是WINDOWS98之前的操作系统的缺省协议。NetBEUI协议是一种短小精悍、通信效率高的广播型协议,安装后不需要进行设置,特别适合于在“网络邻居”传送数据。所以建议除了TCP/IP协议之外,小型局域网的计算机也可以安上NetBEUI协议。另外还有一点要注意,如果一台只装了TCP/IP协议的WINDOWS98机器要想加入到WINNT域,也必须安装NetBEUI协议。

IPX/SPX协议本来就是Novell开发的专用于NetWare网络中的协议,但是现在也非常常用--大部分可以联机的游戏都支持IPX/SPX协议,比如星际争霸,反恐精英等等。虽然这些游戏通过TCP/IP协议也能联机,但显然还是通过IPX/SPX协议更省事,因为根本不需要任何设置。除此之外,IPX/SPX协议在局域网络中的用途似乎并不是很大,如果确定不在局域网中联机玩游戏,那么这个协议可有可无。

如果你还想了解更多这方面的信息,记得收藏关注本站。

tcp ip之外的3种协议(除了tcp ip协议的网络外还有什么协议的网络)

本文编辑:admin

更多文章:


idea控制台乱码(idea 输出 System.out.println() 控制台乱码)

idea控制台乱码(idea 输出 System.out.println() 控制台乱码)

各位老铁们,大家好,今天由我来为大家分享idea控制台乱码,以及idea 输出 System.out.println() 控制台乱码的相关问题知识,希望对大家有所帮助。如果可以帮助到大家,还望关注收藏下本站,您的支持是我们最大的动力,谢谢大

2026年10月14日 07:30

抹茶冰皮月饼(冰皮月饼的做法)

抹茶冰皮月饼(冰皮月饼的做法)

大家好,抹茶冰皮月饼相信很多的网友都不是很明白,包括冰皮月饼的做法也是一样,不过没有关系,接下来就来为大家分享关于抹茶冰皮月饼和冰皮月饼的做法的一些知识点,大家可以关注收藏,免得下次来找不到哦,下面我们开始吧!

2026年10月14日 06:20

spring事务的作用(为什么要使用spring的事务,一般在什么情况下使用)

spring事务的作用(为什么要使用spring的事务,一般在什么情况下使用)

“spring事务的作用”相关信息最新大全有哪些,这是大家都非常关心的,接下来就一起看看spring事务的作用(为什么要使用spring的事务,一般在什么情况下使用)!

2026年10月14日 05:40

网站开发项目计划书(网站建设项目策划书)

网站开发项目计划书(网站建设项目策划书)

大家好,关于网站开发项目计划书很多朋友都还不太明白,不过没关系,因为今天小编就来为大家分享关于网站建设项目策划书的知识点,相信应该可以解决大家的一些困惑和问题,如果碰巧可以解决您的问题,还望关注下本站哦,希望对各位有所帮助!

2026年10月14日 04:50

linux怎么进入命令行(怎么样配置linux使其启动时直接登录到命令行模式)

linux怎么进入命令行(怎么样配置linux使其启动时直接登录到命令行模式)

大家好,关于linux怎么进入命令行很多朋友都还不太明白,不过没关系,因为今天小编就来为大家分享关于怎么样配置linux使其启动时直接登录到命令行模式的知识点,相信应该可以解决大家的一些困惑和问题,如果碰巧可以解决您的问题,还望关注下本站哦

2026年10月14日 02:00

java培训机构好还是大学好(大学生想转行学java,该去java培训班还是自学呢)

java培训机构好还是大学好(大学生想转行学java,该去java培训班还是自学呢)

其实java培训机构好还是大学好的问题并不复杂,但是又很多的朋友都不太了解大学生想转行学java,该去java培训班还是自学呢,因此呢,今天小编就来为大家分享java培训机构好还是大学好的一些知识,希望可以帮助到大家,下面我们一起来看看这个

2026年10月13日 23:30

各种花边图案(花边怎么画 简单易学的花边绘画教程)

各种花边图案(花边怎么画 简单易学的花边绘画教程)

各位老铁们,大家好,今天由我来为大家分享各种花边图案,以及花边怎么画 简单易学的花边绘画教程的相关问题知识,希望对大家有所帮助。如果可以帮助到大家,还望关注收藏下本站,您的支持是我们最大的动力,谢谢大家了哈,下面我们开始吧!

2026年10月13日 19:10

stewardess读音(空姐的英文读音)

stewardess读音(空姐的英文读音)

本篇文章给大家谈谈stewardess读音,以及空姐的英文读音对应的知识点,希望对各位有所帮助,不要忘了收藏本站喔。

2026年10月13日 19:00

前端面试必背十个点(资深HR揭秘:Web前端面试技巧有哪些)

前端面试必背十个点(资深HR揭秘:Web前端面试技巧有哪些)

“前端面试必背十个点”相关信息最新大全有哪些,这是大家都非常关心的,接下来就一起看看前端面试必背十个点(资深HR揭秘:Web前端面试技巧有哪些)!

2026年10月13日 17:50

sqlplus重置用户名密码(Oracle中的plus的用户名和密码忘了怎么办)

sqlplus重置用户名密码(Oracle中的plus的用户名和密码忘了怎么办)

大家好,关于sqlplus重置用户名密码很多朋友都还不太明白,不过没关系,因为今天小编就来为大家分享关于Oracle中的plus的用户名和密码忘了怎么办的知识点,相信应该可以解决大家的一些困惑和问题,如果碰巧可以解决您的问题,还望关注下本站

2026年10月13日 17:40

最近更新

沧州东光商城网站建设预算多少合适
2026-10-14 11:06:28 浏览:0
热门文章

sql server2008下载地址(如何下载SQL Server 2008 R2 SP2免费版)
2026-10-05 05:30:29 浏览:6
thinkpadx100eu盘启动(thinkpad x100e U盘启动 支持的写入方式是什么)
2026-09-01 14:20:01 浏览:6
标签列表